Search found 167 matches

by rowdy1
Fri Oct 05, 2018 8:22 pm
Forum: Aircraft Power Only
Topic: 520 Continental rebuild
Replies: 127
Views: 7658

Re: 520 Continental rebuild

I have been chasing what I thought was an intake leak thus a lean condition this whole time. I will clarify, I have an extra set of fresh cylinders to install on the engine now. The vernatherm was plugged by threading the passage between it inlet and outlet for the oil cooler so oil has to flow thru...
by rowdy1
Fri Oct 05, 2018 7:28 pm
Forum: Aircraft Power Only
Topic: 520 Continental rebuild
Replies: 127
Views: 7658

Re: 520 Continental rebuild

Oil pressure was over 80 cold, even with the main bearings trashed, at 230* it was over 50. I belive I am responsible for the bearing problem. I ran it way to hot and lost oil pressure. It did come back after cooling but Im sure the damage was already done.
by rowdy1
Fri Oct 05, 2018 7:14 pm
Forum: Aircraft Power Only
Topic: 520 Continental rebuild
Replies: 127
Views: 7658

Re: 520 Continental rebuild

It is supposed to have a 661 cam. It and the lifters show absolutely no wear. Honestly there didn't seam to be much lash at all before dismantling. There is nothing to adjust so im not sure how you would change that. The motor was built by a guy that at one time built a good motor in north FL, I won...
by rowdy1
Thu Oct 04, 2018 8:57 pm
Forum: Aircraft Power Only
Topic: carburetor
Replies: 18
Views: 1292

Re: carburetor

Greg did mine last month, It looks better than new and works great. Only took 5 days door to door.
by rowdy1
Thu Oct 04, 2018 4:30 pm
Forum: Aircraft Power Only
Topic: 520 Continental rebuild
Replies: 127
Views: 7658

Re: 520 Continental rebuild

I have a set of Superior cylinders that are take offs w/ 450 hrs. They had an AD for injector bosses or something. They are complete including pistons, pins, rocker arms, everything. I spoke to a builder this morning that said the same thing about the cam. He suggested a set of 10-1 ross pistons and...
by rowdy1
Wed Oct 03, 2018 9:15 pm
Forum: Aircraft Power Only
Topic: 520 Continental rebuild
Replies: 127
Views: 7658

520 Continental rebuild

I have my 520 Continental scattered across a sheet of plywood. I have been posting on and off for over 3 years about an overheating problem. I have rebuilt the carb, resealed the intakes, replaced the rubber boots and clamps, installed pacemaker ign, changed the oil cooler 3 times. Nothing has fixed...
by rowdy1
Mon Sep 03, 2018 8:07 pm
Forum: Aircraft Power Only
Topic: 0470 overheating and running rough
Replies: 45
Views: 2460

Re: 0470 overheating and running rough

My 520 is doing the same thing, I have resealed all of the intakes and re clamped all of the boots. I can not find the leak. Look for a black oil like substance in the intake. Im told that is a sure sign of an intake leak.
by rowdy1
Sun Jul 01, 2018 4:45 pm
Forum: Aircraft Power Only
Topic: Gitsu 0520 Crankcase venting.
Replies: 6
Views: 676

Re: Gitsu 0520 Crankcase venting.

I installed a Morso catch can on my 520 on the port side right where the a/c oil cooler would have mounted. My mistake was to use an automotive style, K & N breather on top. It made a huge mess. Next I installed a crank case scavenger off of the port side header. That made it worse!
by rowdy1
Mon May 14, 2018 9:21 am
Forum: Aircraft Power Only
Topic: Best hull size for a 520
Replies: 16
Views: 1407

Re: Best hull size for a 520

I have a 14 X 8 Poor Boys w/ 3/16 bottom, 3/8 poly and 3/4 deck over. I have a 520 w/ a 72" NGQ set @ 2.5 and it goes like hell. It will stay on plane at 1500, cruises at 1850 - 2100. It is not a race boat! I use it for fishing around Cedar Key.
by rowdy1
Wed Apr 18, 2018 9:28 pm
Forum: Aircraft Power Only
Topic: Mean little 4 cyl.
Replies: 34
Views: 6704

Re: Mean little 4 cyl.

So the next question is: Is it worth doing? Can I get 150 hp out of it? Again, I am wanting to build a "sporty" little deck over ride boat.
by rowdy1
Wed Apr 18, 2018 10:34 am
Forum: Aircraft Power Only
Topic: Mean little 4 cyl.
Replies: 34
Views: 6704

Re: Mean little 4 cyl.

Its been a while but I'm back on this project. I found a complete o290 that needs a little work. Can you put o360 or o540 cylinders on the o290 case?
by rowdy1
Tue Mar 06, 2018 11:46 am
Forum: Airboat Talk
Topic: Mags
Replies: 6
Views: 734

Re: Mags

What type mags are you looking to rebuild, I just remover a pair off of my 520 and installed Pacemaker. These mags have about 10 hours on them, and I would sell them. They are complete and all leads, are good, although one has spot where the insulation is cut. It does not effect running. Im in Willi...
by rowdy1
Wed Nov 15, 2017 5:02 pm
Forum: Hunting & Fishing
Topic: Frogging in Levy County?
Replies: 9
Views: 1068

Re: Frogging in Levy County?

The islands are floating vegetation. Getting up on them is easy, but if you stop you will need a crane to get off.
by rowdy1
Wed Nov 15, 2017 4:56 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

Right side of the engine, under the center cylinder. (Looking at it from the prop)
by rowdy1
Wed Nov 15, 2017 9:03 am
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

Yes Sir, Thank you. The plug is in the passageway, I have even used a depth gauge to make sure it is not in to far, thereby blocking off the outlet. I am in the process of threading the vernatherm cap and installing a temporary oil pressure gauge to check the pressure. I am wondering if there is a p...
by rowdy1
Tue Nov 14, 2017 8:33 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

I'm asking this as a question, I don't want this to come off as smart ass. If the plug is in the motor, how is it possible to not have oil moving thru the cooler? The original problem is that there seemed to be no flow. When the oil temp was 230, both sides of the cooler read 135- 140. That's is why...
by rowdy1
Mon Nov 13, 2017 10:08 am
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

Fresh motor, still on mineral oil w/ about 25 hours. Just stopped consuming oil. Little to no blow by.
by rowdy1
Sun Nov 12, 2017 7:24 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

Update: I removed the valve only to find there was no "guts" in it. The block had been tapped and a plug installed. I removed the plug, installed a valve and ran the boat on the trailer again. Oil temp got up to 190 deg., valve opened, the cooler was 190 on the inlet side, 145 on the outle...
by rowdy1
Thu Nov 09, 2017 1:34 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

That's todays project, I am going to pull the vernatherm out. (if I can find a thin wall 1 1/2 socket)
by rowdy1
Wed Nov 08, 2017 7:33 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

OK, I did a test today. I ran the boat on the trailer at 1900rpms and monitored EGTs and oil temp with my temp gun. It took 21 minutes to go from 0 to 230 degrees on the oil temp. It never got more that 135 deg, on the inlet or outlet side of the oil cooler. There is definitely no flow to the oil co...
by rowdy1
Thu Nov 02, 2017 3:06 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Re: Oil temp issue

Two different hulls, two different gauges, same issue. I forgot to mention that in the original post.
by rowdy1
Wed Nov 01, 2017 8:13 pm
Forum: Aircraft Power Only
Topic: Oil temp issue
Replies: 17
Views: 1731

Oil temp issue

I have a Cont. 520. It has the vernatherm valve in it and a Hayden 1260 oil cooler on it, the temp sender is in the block below where the oil lines come out. Its a sand cast motor. The problem I have is that the oil temp. It warms up slowly (according to the gauge). However after 150 deg. it goes st...
by rowdy1
Thu Sep 07, 2017 4:07 pm
Forum: Mini-Airboats
Topic: Harley motors
Replies: 5
Views: 1084

Re: Harley motors

The guys at Hartline did a "black Widow" boat around 2003 with 2 Harley motors on it, with custom belt drives. The boat was to heavy and did not perform well. I think it was around 11'- 12 ' feet long. Those motors are not happy @ a constant 4500 rpm.
by rowdy1
Sun Aug 13, 2017 7:39 pm
Forum: Airboat Talk
Topic: Poorboys 'Performance'
Replies: 6
Views: 1249

Re: Poorboys 'Performance'

Is that 14 or 15 ft? I hope my hull is next in line at PB. I ordered a 14x8. Also are you in Williston or Levy County? Id like to look at your set up before William starts mine.
Thanks
by rowdy1
Tue Aug 01, 2017 1:06 pm
Forum: Aircraft Power Only
Topic: LYC. 540 rods in a 520 Continental
Replies: 2
Views: 907

Re: LYC. 540 rods in a 520 Continental

Thank You!
I had to believe there was more to the story than just what I had read. Im already working on a multi port EFI conversion plus coil on plug ignition. Sounds like I don't need to undertake this project as well.

Go to advanced search