Need HELP!!

Longest running airboat discussion on the internet.
Post Reply
Boogie320
Southern Airboat Member
Posts: 9
Joined: Wed Jun 14, 2017 6:10 am
Location: Pembroke Pines FL

Need HELP!!

Post by Boogie320 » Fri Jul 21, 2017 6:57 am

So in new to the airboat world and I bought 10' boat with a O-290 GPU 125 HP. It started the first 3 different times and now i can't get it to start. I checked the battery, battery cables everything is getting power. Fuel pump is pumping and is getting fuel to the engine but it just won't crank over. If anyone has any suggestions it would be a great help.

Thanks!!

User avatar
BANANA BOAT
Site Supporter - I
Site Supporter - I
Posts: 1161
Joined: Tue Sep 21, 2010 3:52 pm

Re: Need HELP!!

Post by BANANA BOAT » Fri Jul 21, 2017 6:58 am

Spark, compression and fuel

Sent from my SAMSUNG-SM-T377A using Southern Airboat mobile app powered by Tapatalk

jeepinocala1111
Site Supporter - I
Site Supporter - I
Posts: 1150
Joined: Mon Apr 21, 2014 5:57 pm

Re: Need HELP!!

Post by jeepinocala1111 » Fri Jul 21, 2017 7:05 am

Is the starter turning it over? If so I would say make sure the mag is not grounded. There is a small wire coming out of the mag or mags if it is grounded that is how you turn them off.

Swamp Thang
Southern Airboat Member
Posts: 51
Joined: Mon Jul 25, 2016 9:32 pm
Location: Hudson and Inverness Fl.

Re: Need HELP!!

Post by Swamp Thang » Fri Jul 21, 2017 8:24 am

jeepinocala1111 wrote:Is the starter turning it over? If so I would say make sure the mag is not grounded. There is a small wire coming out of the mag or mags if it is grounded that is how you turn them off.
Whatever you do just make sure you don't put power to the mags because you'll burn them up, when they are Off they are grounded and Not grounded is On
if you determine it is a spark/mag issue call Gmac76 on SA...Greg is a good guy who will fix it right for a reasonable price 863-659-1331
Last edited by Swamp Thang on Fri Jul 21, 2017 7:26 pm, edited 1 time in total.

GMAC 76
Site Supporter - V
Site Supporter - V
Posts: 1235
Joined: Sun Jan 04, 2009 11:12 pm
Location: LAKE PLACID FL.... LAKE ISTOKPOGA

Re: Need HELP!!

Post by GMAC 76 » Fri Jul 21, 2017 9:08 am

you said it wont crank over so I assume your saying the starter will not turn the engine over so it will start....so starter, starter switch or wiring to starter

User avatar
kwanjangnihm
Site Supporter - IV
Site Supporter - IV
Posts: 1925
Joined: Sat Mar 30, 2013 8:23 pm
Location: Bartow FL

Re: Need HELP!!

Post by kwanjangnihm » Fri Jul 21, 2017 11:00 am

Mine would not start about a month ago. Charger showed a full charge but when I hit the button NADA!
Had the battery checked and it had a dead cell (only 9volts). Was under warranty. New battery worked like a charm!! :thumbleft:
" I don't care who you are back in the world, you give away our position one more time, I'll bleed ya, real quiet. Leave ya here. Got that? "

Boogie320
Southern Airboat Member
Posts: 9
Joined: Wed Jun 14, 2017 6:10 am
Location: Pembroke Pines FL

Re: Need HELP!!

Post by Boogie320 » Fri Jul 21, 2017 11:09 am

Swamp Thang wrote:
jeepinocala1111 wrote:Is the starter turning it over? If so I would say make sure the mag is not grounded. There is a small wire coming out of the mag or mags if it is grounded that is how you turn them off.
Whatever you do just make sure you don't put power to the mags because you'll burn them up, when they are ON they are grounded and Not grounded is OFF
if you determine it is a spark/mag issue call Gmac76 on SA...Greg is a good guy who will fix it right for a reasonable price 863-659-1331
Yes starter turns over. So when starting megs have to be grounded correct?

Boogie320
Southern Airboat Member
Posts: 9
Joined: Wed Jun 14, 2017 6:10 am
Location: Pembroke Pines FL

Re: Need HELP!!

Post by Boogie320 » Fri Jul 21, 2017 11:10 am

kwanjangnihm wrote:Mine would not start about a month ago. Charger showed a full charge but when I hit the button NADA!
Had the battery checked and it had a dead cell (only 9volts). Was under warranty. New battery worked like a charm!! :thumbleft:

Ya I tested the battery and I'm getting 13v all the way around.

GMAC 76
Site Supporter - V
Site Supporter - V
Posts: 1235
Joined: Sun Jan 04, 2009 11:12 pm
Location: LAKE PLACID FL.... LAKE ISTOKPOGA

Re: Need HELP!!

Post by GMAC 76 » Fri Jul 21, 2017 11:27 am

Boogie320 wrote:
Swamp Thang wrote:
jeepinocala1111 wrote:Is the starter turning it over? If so I would say make sure the mag is not grounded. There is a small wire coming out of the mag or mags if it is grounded that is how you turn them off.
Whatever you do just make sure you don't put power to the mags because you'll burn them up, when they are ON they are grounded and Not grounded is OFF
if you determine it is a spark/mag issue call Gmac76 on SA...Greg is a good guy who will fix it right for a reasonable price 863-659-1331
Yes starter turns over. So when starting megs have to be grounded correct?
NO......if mags ARE GROUNDED they will NOT FIRE....grounding the mags is what shuts them off

diamondback0320
Southern Airboat Member
Posts: 1320
Joined: Thu Aug 20, 2009 3:09 pm
Location: palm bay,fl

Re: Need HELP!!

Post by diamondback0320 » Fri Jul 21, 2017 12:48 pm

You got to it B4 I could Greg..GOOD CATCH!!

GMAC 76
Site Supporter - V
Site Supporter - V
Posts: 1235
Joined: Sun Jan 04, 2009 11:12 pm
Location: LAKE PLACID FL.... LAKE ISTOKPOGA

Re: Need HELP!!

Post by GMAC 76 » Fri Jul 21, 2017 1:06 pm

diamondback0320 wrote:You got to it B4 I could Greg..GOOD CATCH!!
great minds............uh tony...lol

Boogie320
Southern Airboat Member
Posts: 9
Joined: Wed Jun 14, 2017 6:10 am
Location: Pembroke Pines FL

Re: Need HELP!!

Post by Boogie320 » Fri Jul 21, 2017 1:46 pm

GMAC 76 wrote:
diamondback0320 wrote:You got to it B4 I could Greg..GOOD CATCH!!
great minds............uh tony...lol
Thank You I appreciate it
ill let you know how it goes. when i get out of work lol.

Swamp Thang
Southern Airboat Member
Posts: 51
Joined: Mon Jul 25, 2016 9:32 pm
Location: Hudson and Inverness Fl.

Re: Need HELP!!

Post by Swamp Thang » Fri Jul 21, 2017 7:34 pm

Corrected my post, sorry Boogie it was late and meant to say it the opposite way like Jeepin & Greg said.

Post Reply

Return to “Airboat Talk”