Ls boat will not stay running

Automotive powered airboat discussion.
Post Reply
Cutler
Southern Airboat Member
Posts: 211
Joined: Tue Feb 21, 2012 8:10 pm
Location: Miami

Ls boat will not stay running

Post by Cutler »

I've a brand new boat with a Ls motor and have a problem I can't figure and need some help, the boat starts fine and will accelerate but will only run about 5 seconds or less then stalls, holds good fuel pressure the whole time at the injection rail. Anybody got any ideas?had the computer re flashed and not a 100% sure that that is not the problem

Afflicted
Site Supporter - I
Site Supporter - I
Posts: 419
Joined: Thu Jan 19, 2012 12:22 pm

Re: Ls boat will not stay running

Post by Afflicted »

My 8.1 was doin that when I first got it together and I had to have the computer completley retuned.. After it was supposed to be right

User avatar
Smuggler
Site Supporter - VII
Site Supporter - VII
Posts: 1587
Joined: Thu Aug 02, 2007 10:12 am
Location: Brooksville FL

Re: Ls boat will not stay running

Post by Smuggler »

My guess would be the VATS is still enabled. Usually when you have a ECU programmed you have to specifically ask for them to delete the VATS and emissions.

Afflicted
Site Supporter - I
Site Supporter - I
Posts: 419
Joined: Thu Jan 19, 2012 12:22 pm

Re: Ls boat will not stay running

Post by Afflicted »

I Thought that's what mine was but it wasn't. But I bet that's probably what his problem is.

ls1airboat
Southern Airboat Member
Posts: 192
Joined: Mon Feb 17, 2014 4:19 pm
Location: leesburg

Re: Ls boat will not stay running

Post by ls1airboat »

its the vats.i can tell you how to check it..i sent you a pm with my number

Cutler
Southern Airboat Member
Posts: 211
Joined: Tue Feb 21, 2012 8:10 pm
Location: Miami

Re: Ls boat will not stay running

Post by Cutler »

Thanks you guys, we disconnected the mass air flow sensor and now it runs, but we now have to figure out what's causing that

User avatar
akblackdawg
Site Supporter - III
Site Supporter - III
Posts: 2969
Joined: Mon Jun 29, 2009 1:53 am
Location: Wasilla, ALASKA

Re: Ls boat will not stay running

Post by akblackdawg »

you say you have a brand new boat, I would be talking to the builders, if it is screwed up, they need to fix it, not you. even if not close to you, call them, still their responsibility. Bud
:alaska: If you ain't living on the edge, you're taking up to much space.

15x8 Alumatech hull, with enclosed cab, aluminum cage, LS 3, 6.2 aluminum block ffi, 2.7 Balistic Box, sensinich superwide 3 blade. Built for year around riding in Alaska

Cutler
Southern Airboat Member
Posts: 211
Joined: Tue Feb 21, 2012 8:10 pm
Location: Miami

Re: Ls boat will not stay running

Post by Cutler »

It's a don Davis hull, but he only built the boat, we did the rest,but thank you. I think we might have it figured out, just have to figure out what to do with the map sensor,we are going to call the guy that did the computer today to see what he says

User avatar
Bagman
Site Supporter - III
Site Supporter - III
Posts: 682
Joined: Fri Feb 08, 2008 3:49 pm
Location: Gardner FL

Re: Ls boat will not stay running

Post by Bagman »

Had a similar issue with mine when I built it. I'm running speed density tune so no MAF, but I had an issue with my MAP sensor pins at that ECM. The harness had the 3 MAP sensor wires one pin off. Moved them to the correct position and problem solved. I was able to pull codes on mine. Have you scanned yours for any codes? It really helped me pin point the issue.
14 x 7' 10" DynaMarine Velocity, 2.5 Ballistic gear drive, Supercharged LS, 3 blade NGR
Whiplash Performance Marine

Cutler
Southern Airboat Member
Posts: 211
Joined: Tue Feb 21, 2012 8:10 pm
Location: Miami

Re: Ls boat will not stay running

Post by Cutler »

Thank you bagman, we think we have it narrowed down to a wiring issue, still waiting on them to call back,

Cutler
Southern Airboat Member
Posts: 211
Joined: Tue Feb 21, 2012 8:10 pm
Location: Miami

Re: Ls boat will not stay running

Post by Cutler »

Do you guys run a thermostat? If so what temp, or can you run some sort of restrictor

User avatar
Bagman
Site Supporter - III
Site Supporter - III
Posts: 682
Joined: Fri Feb 08, 2008 3:49 pm
Location: Gardner FL

Re: Ls boat will not stay running

Post by Bagman »

160 thermostat in mine and have it tuned for it.
14 x 7' 10" DynaMarine Velocity, 2.5 Ballistic gear drive, Supercharged LS, 3 blade NGR
Whiplash Performance Marine

User avatar
mercracing
Southern Airboat Member
Posts: 12
Joined: Tue Apr 23, 2013 9:10 pm
Location: Homestead, FL
Contact:

Re: Ls boat will not stay running

Post by mercracing »

Cutler wrote:Do you guys run a thermostat? If so what temp, or can you run some sort of restrictor
160 in mine as well.
"TOTAL LOSS"
13' Al David (performance airboats) family boat with a old worn out junkyard LS and 6 blade prop

Post Reply

Return to “Automotive Power Only”