Having issues with oil temp sensor and incorrect reading???

A general, non-powerplant specific, discussion on airboat technology, ie., hulls, rigging, polymer, etc..
Post Reply
Salty Techsan
Southern Airboat Member
Posts: 35
Joined: Thu Oct 24, 2013 1:17 am

Having issues with oil temp sensor and incorrect reading???

Post by Salty Techsan »

Thanks in advance for any guidance! Purchased an older Texas built boat with a 220/0-470 GPU on her, and have had issues with misreadings on oil temp gauge from the get go. Replaced both the sensor (type that screws into the drain plug hole in bottom of oil pan), and the gauge, but still getting a reading that is about 100 degrees or so above actual temp. I have checked oil temp with infared gun, and even sanity checked that with cup of hot water and getting same results. I have replaced both the sensor, and the damn guage (faria/Teleflex brand purchased from local marine supply place). I've triple checked that all is hooked up correctly, and made sure I'm getting good ground, etc. Any ideas on what the hell is going on? If gauge were actually a water temp vs. oil temp gauge, could that affect anything?

on a side note.. I am installing CHT sensors and gauge as well to monitor engine health, but would still like to be able to accurately see oil temp as well. Thanks a ton!

Kyle in Texas.

SWAMPHUNTER45
Site Supporter - III
Site Supporter - III
Posts: 3058
Joined: Thu Nov 21, 2013 11:38 am
Location: Naturecoast, Florida

Re: Having issues with oil temp sensor and incorrect reading

Post by SWAMPHUNTER45 »

Can you verify the oil sender and gauge match ranges? Ohm range

GMAC 76
Site Supporter - V
Site Supporter - V
Posts: 1274
Joined: Sun Jan 04, 2009 11:12 pm
Location: LAKE PLACID FL.... LAKE ISTOKPOGA

Re: Having issues with oil temp sensor and incorrect reading

Post by GMAC 76 »

put a mechanical gauge on her.....simple and accurate

Salty Techsan
Southern Airboat Member
Posts: 35
Joined: Thu Oct 24, 2013 1:17 am

Re: Having issues with oil temp sensor and incorrect reading

Post by Salty Techsan »

I wasn't aware of the OHM ranges varied on different gauges.. but that could definately explain it. Any idea how I would be able to tell that? I like the idea of a mechanical gauge as well.. where could I get one of those that would jive with my 220 GMAC 76?

Many thanks!

User avatar
nomad41
Site Supporter - VI
Site Supporter - VI
Posts: 4302
Joined: Tue Sep 18, 2007 5:12 pm
Location: Palmetto,Fl

Re: Having issues with oil temp sensor and incorrect reading

Post by nomad41 »

If you are using a Faria guage you have to use their sender. And understand Teleflex and Faria are 2 different companies. And both will tell you us their senders only.
http://www.flickr.com/photos/nomad41/
Treasurer FAA
Member:FAA, KRVSA ,IRCAA, FSCA

My old boat 14.5x8 Diamondback ,SBC Stroker,2.68 Stinger,Sensenich 82" R
Svcliche@yahoo.com

Salty Techsan
Southern Airboat Member
Posts: 35
Joined: Thu Oct 24, 2013 1:17 am

Re: Having issues with oil temp sensor and incorrect reading

Post by Salty Techsan »

Many thanks gentlemen. My local auto parts store had a mechanical gauge, so I picked up for $80 and installed last night. Hopefully I'll be good to go. Thanks again for the help!

SWAMPHUNTER45
Site Supporter - III
Site Supporter - III
Posts: 3058
Joined: Thu Nov 21, 2013 11:38 am
Location: Naturecoast, Florida

Re: Having issues with oil temp sensor and incorrect reading

Post by SWAMPHUNTER45 »

Just for info only, I have found that the Autometer mechanical temperature gauges are super accurate and tend to be a bit better made with the coated thermal tube and anodized fittings.

Let us know the results

Post Reply

Return to “Airboat Tech”