ECOTEC 2.0 LTG SWAP

Automotive powered airboat discussion.
FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Image

Spacers for the soft drive.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Which LTG compatible ECM’s would you consider most desirable? Any that a person should stay away from?

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Yes it’s Wednesday. Good shot placement on a 100# AJ
Image

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

ImageExhaust 90 and vband welded up

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Intercooler pipe all done
Image

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Spoke to Swaptime and he said go ahead and crank it. He disabled all the Nany stuff already in the tune. May crank it Friday morning.
Image

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Went to spin the motor over with no fuel to build oil pressure and it started🙂. Must have had a little fuel left in the fuel rail. Only ran for a second or two. Turned it over for a bit. Will run it in the morning. Feeling optimistic.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Success
Image

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Well, Tried to post a link to the video. It cranks and runs. Did not have the gearbox bolted to the flex plat so there was zero load. Idle is real low and if i rev it to 2500 it will not drop off idle so there are a few issues. I have a few codes to look up and see what they are. I think Im going to bolt up the soft drive to add a little more load on the motor.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Image

User avatar
OneBFC
Southern Airboat Member
Posts: 639
Joined: Tue Sep 11, 2012 1:04 am

Re: ECOTEC 2.0 LTG SWAP

Post by OneBFC »

Yep, tuner did what tuners do. Fail hard core at doing what they said they were going to do.

You have several sensors that need to have their faults turned off.

It's that or you have some sensors to work out the issues on. Just look up those codes and go one by one.
-Russ
-----------------------------------
The only thing stopping you is FEAR
400+hp Ecotec, 12x7.6 DBDO, 80" 3B Maximus, 2.3 OX,85+mph, water = purely optional
Life begins at 2 BAR, Just a good ole boy

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Well, found one of my problems today. A few emails to Mitch at Swap time who put my harness and ECM package together pointed out that I have a boost sensor missing in my setup. A connector that is currently not connected I wrongfully assumend was something to do with emissions and instead it was the damn 4 pin connector for the boost sensor. Thats what happens when you don't have the factory sevice manual / engine wiring diagrams. You assume shit. BIG thanks to Mitch for helping me out on a Sunday no less. I told him to just call me sometime tomorrow but he insisted on helping me today. Thanks again Mitch. I think I still have an o2 sensor issue but i'll have to see after I get this boost sensor put into the system. And my AHP TIG machine took a dump. Have to send that back this week. I guess we will see how good that 3 year warranty is.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Don’t cut this plug off!
Image

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Image

User avatar
OneBFC
Southern Airboat Member
Posts: 639
Joined: Tue Sep 11, 2012 1:04 am

Re: ECOTEC 2.0 LTG SWAP

Post by OneBFC »

Glad to hear your getting support. Simple issue to fix too, so win win!
-Russ
-----------------------------------
The only thing stopping you is FEAR
400+hp Ecotec, 12x7.6 DBDO, 80" 3B Maximus, 2.3 OX,85+mph, water = purely optional
Life begins at 2 BAR, Just a good ole boy

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Picked up my boost sensor today. Need to make a little pad to fit it to the intercooler pipe.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Did the video show up for you guys? It plays on my phone but not on my PC.

User avatar
OneBFC
Southern Airboat Member
Posts: 639
Joined: Tue Sep 11, 2012 1:04 am

Re: ECOTEC 2.0 LTG SWAP

Post by OneBFC »

Dont see video posted here, so, nope! Only way I know to get video on this forum is to upload to youtube and then copy the YouTube link to your post.
-Russ
-----------------------------------
The only thing stopping you is FEAR
400+hp Ecotec, 12x7.6 DBDO, 80" 3B Maximus, 2.3 OX,85+mph, water = purely optional
Life begins at 2 BAR, Just a good ole boy

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

10-4. I’ll see about posting it up on YouTube. Without a signal from the boost sensor the ECM was pouring fuel in at idle. Don’t have to be an expert to read these plugs.
Image

Birdslayer86
Southern Airboat Member
Posts: 13
Joined: Sat Jan 21, 2017 11:26 am
Location: Bradenton FL

Re: ECOTEC 2.0 LTG SWAP

Post by Birdslayer86 »

I can see the video from my phone. I don’t own a desktop so not sure about that. There is no sound on the video though

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

Interesting. I copied the link for the Video from IMGU app. Birdslayer tap the video and see if it adds the sound. On my iphone it will. Do you have the IMGUR app? Just wondering if that has anything to do with being able to see the video.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

The harness on the motor currently is a 2016 Camaro standard transmission part (slightly modified). The motor was out of a 2016 Malibu. I have the uncut harness from the Malibu. The plugs on the two for the boost sensor are different. But GM shows the same part number for both. Both are 4 pin. The sensor snaps into the Malibu harness perfectly and locks like it should. The harness on the motor that is for a 2016 Camaro will not accept the sensor. If I ground off two tabs I am sure it would fit but I can not tell the proper orientation of the connection. And of course the wire colors are different between the two harness. I’ll let you know when I solve the puzzle.

Birdslayer86
Southern Airboat Member
Posts: 13
Joined: Sat Jan 21, 2017 11:26 am
Location: Bradenton FL

Re: ECOTEC 2.0 LTG SWAP

Post by Birdslayer86 »

I do not have the app that I’m aware of. But no matter what I try no sound.

FISHSTICKER
Southern Airboat Member
Posts: 364
Joined: Wed Aug 31, 2016 11:22 am
Location: French Settlement Louisiana

Re: ECOTEC 2.0 LTG SWAP

Post by FISHSTICKER »

I’m happy to say I didn’t know what I was talking about. The sensor I have does fit the connector with the typical red locking tab on the Malibu harness. And after more investigation and playing with the other completely different connector.....I find out that it fits as well. If you put the connector on in the correct configuration it goes on a very little bit further but not in all the way. Then you push on the locking tab on the side and the angled slots finish pulling the connector the rest of the way in. I have never seen a connector like this before.
Image

User avatar
OneBFC
Southern Airboat Member
Posts: 639
Joined: Tue Sep 11, 2012 1:04 am

Re: ECOTEC 2.0 LTG SWAP

Post by OneBFC »

Yep, never have to worry about any of the sensor wires coming lose because every one of them uses some type of very secure locking method like that one.

Once you have it inserted and locked correctly, no way it's ever coming out on its own.

Just another reason why the platform is mostly trouble free once you get it setup and sorted.
-Russ
-----------------------------------
The only thing stopping you is FEAR
400+hp Ecotec, 12x7.6 DBDO, 80" 3B Maximus, 2.3 OX,85+mph, water = purely optional
Life begins at 2 BAR, Just a good ole boy

Post Reply

Return to “Automotive Power Only”